Skip NavigationDesign Science: How Science Communicates
Products Solutions Store Support Reference Company View Cart
 
 
TechNote #29: Last modified: 10/20/99
Last reviewed: 10/20/99

Using MathType with Corel Ventura


The information in this document applies to:

MathType 5.x (Windows)

MathType 4.x (Windows)

MathType 3.0 (Windows)

Corel Ventura 10 (Windows)

Corel Ventura 8 (Windows)

Corel Ventura 5 (Windows)

Corel Ventura 4 (Windows)

MathType works well with the latest version of Corel Ventura using cut and paste, OLE, and imported files. The first part of this document discusses specific version issues relating to MathType’s use with Corel Ventura.

 

Ventura 5

Corel Ventura 5 includes a junior version of MathType which Corel calls CorelEquation. This can be accessed using the Insert Special Item/Equation command from the Corel Ventura Edit menu. Currently, Corel Ventura 5 does not properly place equations which are inserted using any other method.

 

If you want to use MathType instead of CorelEquation, follow the directions below titled Making Insert Special Item/Equation Launch MathType in Ventura 5. After following these directions, choosing Insert Special Item/Equation from the Edit menu will launch MathType, as will double-clicking on any equation, including those that were originally created by CorelEquation.

 

After making these adjustments, if you ever want to use the CorelEquation equation editor, you will need to follow the directions below titled Restoring the CorelEquation Equation Editor in Ventura 5.

 

If you want instructions on the standard procedures for inserting and editing equations, see the section, Inserting and Editing Equations.

 

Ventura 8 - 10

In Corel Ventura 8 - 10, there is no reconfigurable option that enables MathType to launch when using the Insert Equation command, like in Ventura 5. This because Ventura 8 - 10 doesn't use OLE to embed equations when using its Insert Equation command. The equation editor in Ventura 5 was a separate application that was accessed via OLE.

 

If you want instructions on the standard procedures for inserting and editing equations, see the section, Inserting and Editing Equations.

 

Note: There is a known issue with Ventura 10 and MathType (4.x - 5.x) that occurs intermediately when editing an existing equation. The MathType window does not redraw correctly from the Ventura window after updating an equation. The Ventura window needs to be minimize in order for the MathType redraw effect to go away. This is an issue in Ventura's handling of OLE objects. Corel has been informed about this issue and any additional information can be viewed on the support section of the Corel web site.

 

Ventura 4 and earlier:

Versions of Corel Ventura earlier than 4 do not accept equations via OLE or Cut (Copy) and Paste, equations must be embedded as EPS files. Ventura 4 and later does support inserting objects via Cut (Copy) and Paste. OLE is still not supported in Corel Ventura 4.

 

If you want instructions on the standard procedures for inserting and editing equations, see the section, Inserting and Editing Equations.

 


Making Insert Special Item/Equation Launch MathType in Corel Ventura 5

  1. Install MathType using the normal procedures in the MathType manual.
  2. In the Program Manager, choose Run from the File menu.
  3. In the Command Line box, type: "REGEDIT -V" (without quotes) and press OK to run the Registration Info Editor.
  4. Choose Find Key from the Search menu.
  5. In the Find Key dialog, type "{00043B42".
  6. Press Find Next. The following key should end up highlighted:

{00043B42-0000-0000-C000-000000000046}=CorelEquation! 1.0 Equation

  1. Choose Add Key from the Edit menu.
  2. Type in the following values:

Key: AutoConvertTo
Value: {0003000B-0000-0000-C000-000000000046}

  1. Press OK.
  2. Choose Save from the File menu.
  3. Choose Exit from the File menu.

Restoring CorelEquation! in Corel Ventura 5

  1. In the Program Manager, choose Run from the File menu.
  2. In the Command Line box, type: "REGEDIT -V" (without quotes) and press OK to run the Registration Info Editor.
  3. Choose Find Key from the Search menu.
  4. In the Find Key dialog, type the following: "{00043B42" (without quotes)
  5. Press Find Next. The following key should end up highlighted:

{00043B42-0000-0000-C000-000000000046}=CorelEquation! 1.0 Equation

  1. With your mouse, select the item below the highlighted key that starts with the word: AutoConvertTo.
  2. Choose Delete Key from the Edit menu.
  3. Choose Save Changes from the File menu.
  4. Choose Exit from the File menu.

Inserting Equations via OLE

To insert equations into a Ventura document via OLE, use the following procedure:

  1. Choose Object from Ventura's Insert menu.
  2. Choose “MathType Equation” from the Insert Object dialog box. MathType will now run.
  3. Create your equation in MathType. When you are finished creating, either close the MathType window or choose “Close and Return...” from MathType’s File menu.
  4. Press “Yes” if MathType asks if you want to update changes.

The equation you created in MathType is now automatically inserted into your document.


Editing Equations via OLE

To edit an existing equation in a Ventura document via OLE, use the following procedure:

  1. Double-click on the equation object you wish to edit from the Ventura document.
  2. MathType will launch with the equation in the MathType workspace.
  3. Edit your equation in MathType. When you are finished editing, either close the MathType window or choose “Close and Return...” from MathType’s File menu.
  4. Press “Yes” if MathType asks if you want to update changes.

The equation you edited in MathType is now automatically inserted into your document with the new changes.


Cut (Copy) and Paste MathType equations into Ventura

To paste equations into a Ventura document, use the following procedure:

  1. Run MathType and create an equation.
  2. Choose Select All from the Edit menu to highlight the equation.
  3. Choose Copy or Cut from the Edit menu.
  4. Switch to Ventura and choose Paste from the Edit menu.

The equation is now placed in your document, and can be double-clicked for editing. 


Importing MathType equation files into Ventura

To import MathType equation files into Ventura:

  1. Create an equation within MathType and then choose Save As.. from the File menu.
  2. Save the equation in any format, to a any location on your computer.
  3. From within Ventura, choose Import Picture from the File menu.
  4. Navigate to the location where you saved the equation and select the file.

The equation you created in MathType is now automatically inserted into your document.